0
Answered

MQTT: no traffic to server

Mauro 10 months ago in Equipment updated by Support Manager 10 months ago 2

I just configured the device.

I enabled mqtt server config wit username and password.

Unfortunately in mqtt logs I cannot see the username from the smart-mac but just:

1557525454: New connection from 10.x.xx.xxx on port 1883.
1557525454: Sending CONNACK to 10x.xx.xxx (0, 5)
1557525454: Socket error on client , disconnecting.

Answered

MQTT settings are simple and it's not easy to say where you can miss. See page 9 of User Manual.

1. The device must be connected to the WiFi Access Point.

2. The device supports only a non-secure connection to the MQTT server.

3. To connect to the MQTT you need a minimum of settings: server address, port, user login, password.

4. After that the device sends topics every minute with the format:

[Device ID].[parameter]

For example:

1728053249.W

1728053249.A

... and 1728053249.JSON with JSON format of all the data.

Do you connect to your own MQTT server?

Did you try to use some public server? For example, www.cloudmqtt.com

After having triple-checked the credential I found an error in username/password to connect to mqtt server (mosquitto rurrning on a Pi)  and I managed to see published all the topics.

Thank You for you support.